KB 167 (ABAP): Application logs cannot be deleted
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Category: Problem |
Priority: High |
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Platform: ABAP |
Version: 1 from 25.01.2023 |
Description
BALHDR and BALDAT tables are growing. Number of records with BALHDR-OBJECT=/BNWVS/ is growing and SLG2 does not remove these records.
The problem is related to SP 7.01.
Cause
Due to the bug, BALHDR-DEL_BEFORE flag is set, which prevents SLG2 from deletion such entries.
Resolution
Please set Application Log Level to ‘No log’ and contact PowerConnect support to get a hotfix transport.
Reduce Application log level (temporary step until hotfix transport is imported or upgrade performed):
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Open /bnwvs/main
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Open Application log settings using Administrator->App Log Level
3. Set log level to 'No Log' and confirm the selection
Once this done, no PowerConnect logs will not be recorded in BALHDR/BALDAT tables.
Hotfix import and logs cleanup:
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Stop PowerConnect jobs.
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Import the transport N71K905234 into the system.
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Use SE38 to run program /BNWVS/BC_SBAL_DELETE (delivered in the transport above) in the client where PowerConnect is running.
The recommendation is to run it in background mode as a job.
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Wait for job completion
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Increase Log Level to 'Error' level
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Start PowerConnect jobs again
Product version
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Product |
From |
To |
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PowerConnect (all ABAP platforms) |
7.01 |
7.01 |